Low FPS on Laptop with integrated Graphics (Solution)

Come Here To Ask Questions
Post Reply
Aldorat
Posts: 5
Joined: Mon Jun 26, 2017 4:17 pm

Low FPS on Laptop with integrated Graphics (Solution)

Post by Aldorat » Mon Aug 14, 2017 7:18 am

So i just bought a new laptop and tried playing FFXI on it only to discover very crappy frame rates and slow movement. The Laptop does have integrated Graphics as well as a dedicated GPU. It turns out that FFXI would somehow always default to the integrated Graphics instead of using the more powerful nvidia GPU. You could easily confirm that by using GPU-Z. No amount of tinkering with the nvidia control panel to force the pol.exe to run on the nvidia GPU helped.

As I could not accept that i thankfully found a solution on the interwebs. As it turns out newer GPUs working in tandem with integrated Graphics tend to default anything Directx8 or below to the integrated Graphics units. FFXI apparently uses Directx8 (or even 7, i'm not sure). A solution to this problem is a custom .dll written by someone way more tech savy than i am. It acts as a proxy so that FFXI will run in Directx9 allowing FFXI to use a dedicated GPU again. Link below:
--
https://www.bluegartr.com/threads/12994 ... (For-FFXI)
http://ashita.atom0s.com/forums/viewforum.php?f=26

It works for retail as well as private servers using either stock version or ashita. Windower seems not to be supported, allthough i did not try it. With ashita and Kupo you simply have to put both files (.dll and .ini) into the ashita/kupoloader folder next to the pol.exe. I also had to disable bump mapping due to rendering errors. There might also be some shadow flickering due to something called z-fighting that can be tweaked in the .ini file.

With that i was finally able to get back up to 60 fps with my nvidia GPU running!

For anyone experiencing the same issues, hopefully this will help you as well.

User avatar
atom0s
Posts: 26
Joined: Sat Feb 18, 2017 4:33 am

Re: Low FPS on Laptop with integrated Graphics (Solution)

Post by atom0s » Mon Aug 28, 2017 9:00 am

I am the author of this (and Ashita), thanks for linking this to others that may have issues. :)

To answer some of your uncertain points:

FFXI does use Direct3D8. The reason this issue happens is because Nvidia Optimus (Nvidia's mobile graphics switching technology) does not work for Direct3D8 and earlier. Only Dx9+ is supported with it. Because of this, older applications such as FFXI will always default to the integrated graphics chip unless your system allows you to specifically turn off the feature or even turn off the integrated chip. This is generally not a thing though on most systems.

My proxy up-ports FFXI's Direct3D8 calls to use Direct3D9 calls instead which causes the system to assume the game is actually using D3D9 allowing Nvidia Optimus to properly pickup the game and use the dedicated graphics.

Windower is not supported at all, the proxy directly prevents it from working/supporting Windower on purpose. It will only work on the stock version of the game or with Ashita.
  • Ashita Lead Developer

Post Reply